Chọn MENU

Hướng dẫn cấu hình cân bằng tải 2 WAN/ nhiều WAN trên Router MikroTik

Router MikroTik là thương hiệu bộ định tuyến nổi tiếng là hiệu năng tốt, nhiều tính năng cao cấp, cấu hình tùy chỉnh đa dạng, giá thành hợp lý tới từ Latvia, châu Âu. Hiện nay, router MikroTik được ưa chuộng trên toàn thế giới và tại rất nhiều doanh nghiệp Việt Nam.

Trong đó, cân bằng tải nhiều đường WAN cộng băng thông là 1 tính năng nổi bật rất được yêu thích của Router MikroTik. MikroTik cho phép cấu hình quy định cổng port bất kỳ làm port WAN đồng thời cho phép cấu hình Load-Balancing cộng không giới hạn nhiều port WAN cùng lúc để chạy đồng thời miễn sao đủ cổng.

Bài viết dưới đây, Việt Tuấn sẽ hướng dẫn bạn cách cấu hình Load Balancing 2 WAN hoặc nhiều WAN trên Router MikroTik chi tiết.

1. Cần chuẩn bị gì trước khi cấu hình Load Balancing trên Router MikroTik?

Yêu cầu & chuẩn bị trước khi thực hiện:

2. Load Balancing và Failover trong MikroTik

2.1. Load Blancing: Cân bằng tải

Cân bằng tải là phương pháp nhằm phân tán lưu lượng truy cập trên nhiều liên kết để có được cách sử dụng liên kết tốt hơn. Điều này có thể được thực hiện cho mỗi gói trong mỗi kết nối hoặc mỗi kết nối với nhau.

2.2. Failover: Chuyển đổi dự phòng

Chuyển đổi dự phòng Failover là cách sử dụng nhiều đường đi (Gateway) với một lần khi lần đầu tiên thất bại. Nó bắt đầu với việc thêm các lối đi (Gateway). Đặt giá trị khoảng cách lớn hơn cho các đường đi dự phòng và luôn chọn kiểm tra trạng thái đường đi chính.

3. Phương pháp cân bằng tải phổ dụng PCC là gì?

Trong bài viết hướng dẫn cấu hình Load Balancing 2 WAN trên Router MikroTik, Việt Tuấn sẽ sử dụng cơ chế cấu hình Load Balancing theo phương pháp cân bằng tải Per Connection Classifier (PCC). PCC là phương pháp cân bằng tải phổ biến trên Router MikroTik.

Vậy PCC là gì?

PCC là viết tắt của cụm từ “Per Connection Classifier”, là một trình so khớp, sẽ cho phép bạn phân chia lưu lượng trong mạng LAN thành các luồng bằng nhau với khả năng giữ các gói với danh sách các bộ tùy chọn cụ thể trong một luồng cụ thể (bạn có thể chỉ định bộ tùy chọn này là src-address, src- port, dst-address, dst-port).

pcc là gì

PCC phân loại theo kết nối:

  • Đơn giản, hiệu quả, có thể mở rộng, không có tác dụng phụ khó chịu.
  • Phương pháp cân bằng tải theo từng địa chỉ.
  • PCC chia dữ liệu đến thành các luồng bằng nhau và sau đó sử dụng quy tắc định tuyến để sắp xếp lưu lượng đồng đều (hoặc không đồng đều) trên nhiều kết nối WAN.

Điều này được thực hiện bởi:

  • Sử dụng thuật toán băm để sắp xếp lưu lượng dựa trên địa chỉ nguồn, cổng nguồn, địa chỉ đích, đích cổng hoặc kết hợp các thuộc tính của chúng với nhau.
  • Sử dụng Mangle đánh dấu gói và chỉ định tuyến và một số đường đi định tuyến nằm trong bảng Route để đảm bảo lưu lượng theo một tuyến đã chỉ định trên mỗi đường WAN.

Tùy chọn trong PCC và việc áp dụng trong mô hình thực tế.

Các gói IP có một tiêu đề chứa một số trường, hai trong số các trường đó là địa chỉ IP của nguồn của gói và địa chỉ IP của đích của gói. Các gói TCP và UDP cũng có các tiêu đề chứa cổng nguồn và cổng đích.

Dưới đây là các tùy chọn trường khác nhau, các trường sẽ được đưa vào thuật toán (và, với mục đích phân tán chúng trên các đường liên kết khác nhau, quyết định gói sẽ được đưa vào). Hãy nhớ rằng hàm băm sẽ luôn tạo ra cùng một đầu vào khi nó được cung cấp cùng một đầu ra:

  • Src-address: Địa chỉ nguồn của máy khách sẽ luôn giống nhau, vì vậy tất cả lưu lượng truy cập từ một máy khách sẽ luôn khớp với cùng một đối sánh PCC và sẽ luôn được đặt trên cùng một đường Internet.
  • Dst address: Địa chỉ đích của một máy chủ sẽ luôn giống nhau, vì vậy tất cả lưu lượng truy cập đến máy chủ đó (giả sử, Mikrotik Wiki) sẽ luôn đặt trên cùng một đường Internet.
  • Both Addresses: Cặp IP nguồn và đích giữa cùng một máy khách tới máy chủ sẽ luôn giống nhau, vì vậy tất cả lưu lượng giữa một máy khách và một máy chủ cụ thể (giả sử, máy tính xách tay của bạn và Mikrotik Wiki) sẽ luôn khớp với cùng một đối sánh PCC , và sẽ luôn được đặt trên cùng một đường Internet.
  • Src-port: Các cổng nguồn của máy khách thường được chọn ngẫu nhiên khi kết nối được tạo, do đó, qua nhiều kết nối, các cổng nguồn khác nhau sẽ được đưa vào hàm băm và các đối sánh PCC khác nhau sẽ khớp và lưu lượng sẽ đi qua các đường Internet khác nhau. Tuy nhiên, một số giao thức, ở máy khách luôn chọn cùng một cổng nguồn và các máy chủ phía sau bộ định tuyến của bạn hầu như sẽ luôn sử dụng cùng một cổng dịch vụ cố định để gửi lưu lượng truy cập trở lại máy khách.
  • Một máy chủ web phía sau bộ định tuyến của bạn sẽ gửi hầu hết lưu lượng truy cập từ các cổng HTTP (80) và HTTPS (443) của nó và lưu lượng đó sẽ luôn khớp với cùng một trình so khớp PCC và sẽ được đặt trên cùng một đường Internet.
  • Dst-port: Cổng đích của máy khách thường là cổng dịch vụ được xác định rõ, cố định. Tất cả lưu lượng HTTP (80) giữa máy khách và máy chủ của bạn trên Internet sẽ luôn khớp với cùng một trình so khớp PCC và sẽ được đặt trên cùng một đường Internet. Tuy nhiên, khách hàng thực hiện lưu lượng HTTPS (443) có thể khớp với một trình so khớp PCC khác và sẽ đi qua một đường Internet khác.
  • Both-ports: Do cổng khách (thường) được chọn ngẫu nhiên và cổng đích trên máy chủ luôn cố định, nên sự kết hợp của hai cổng là (thường) ngẫu nhiên và sẽ truyền tải trên các đường Internet khác nhau.
  • Src-address-and-port: Cùng giống với cơ chế của src-port.
  • Dst-address-and-port<: Cùng giống cơ chế với dst-port.
  • Both-addresses-and-ports: Đây là cách ngẫu nhiên nhất để phân tán lưu lượng truy cập trên các đường Internet vì nó có số lượng biến nhiều nhất.

4. Hướng dẫn cấu hình cân bằng tải nhiều WAN trong Router MikroTik

Có 2 cách để cài đặt cân bằng tải theo phương pháp PCC.

hướng dẫn cấu hình cân bằng tải load balancing

Cách 1. Sử dụng các lệnh trên Winbox

Thận trọng! Sử dụng phương pháp cài đặt bằng câu lệnh, bạn cần nắm vững các yếu tố cố định và yếu tố thay đổi trong câu lệnh.

  • Mô hình 2 đường Internet sử dụng PPPoE
/ip firewall mangle
add action=accept chain=prerouting dst-address=192.168.1.0/24 in-interface=BridgeLAN
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=pppoe-out1 new-connection-mark=VaoWAN1 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=pppoe-out2 new-connection-mark=VaoWAN2 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=BridgeLAN new-connection-mark=DD01 passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=BridgeLAN new-connection-mark=DD02 passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=DD01 in-interface=BridgeLAN new-routing-mark=DiraWAN1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=DD02 in-interface=BridgeLAN new-routing-mark=DiraWAN2 passthrough=yes
add action=mark-routing chain=output connection-mark=VaoWAN1 new-routing-mark=DiraWAN1 passthrough=yes
add action=mark-routing chain=output connection-mark=VaoWAN2 new-routing-mark=DiraWAN2 passthrough=yes
/ip route
add check-gateway=ping distance=1 gateway=pppoe-out1 routing-mark=DiraWAN1
add check-gateway=ping distance=1 gateway=pppoe-out2 routing-mark=DiraWAN2

Với mô hình bên trên, bạn chỉ cần mở giao diện Winbox, chọn thẻ “New Terminal” sao chép và dán câu lệnh để thực hiện.

Bạn cần hiểu các nhóm lệnh và thông số trong lệnh bạn cần lưu ý. Các thông số đã được Highlight.

Cách 2. Sử dụng giao diện Winbox

Mọi câu lệnh sử dụng trên Winbox, đều tương ứng với 1 lệnh khi chúng ta sử dụng giao diện!

  • Cụm 1: 
    • add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=pppoe-out1 new-connection-mark=VaoWAN1 passthrough=yes
    • add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=pppoe-out2 new-connection-mark=VaoWAN2 passthrough=yes

huong-dan-cau-hinh-load-balancing-wan-1.png

huong-dan-cau-hinh-load-balancing-wan-3.png

→ Các kết nối hướng từ bên ngoài Internet đi vào các đường WAN trên Router được đánh dấu lại với giá trị “VaoWAN1” và “VaoWAN2”

  • Cụm 2:
    • add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=BridgeLAN new-connection- mark=DD01 passthrough=yes per-connection-classifier=both-addresses- and-ports:2/0
    • add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=BridgeLAN new-connection- mark=DD02 passthrough=yes per-connection-classifier=both-addresses- and-ports:2/1

Thẻ IPFirewallMangle

huong-dan-cau-hinh-load-balancing-wan-2.png

huong-dan-cau-hinh-load-balancing-wan-4.png

→ Các kết nối xuất phát từ trong mạng LAN ra ngoài (bao gồm cả ra ngoài Internet và xuất phát ra trong mạng nội bộ) được đưa vào hàm xử lí. Khi có kết quả xử lí, các kết nối này lại được đánh dấu lại với giá trị “DD01” và “DD02”

  • Cụm 3:
    • add action=mark-routing chain=prerouting connection-mark=DD01 in- interface=BridgeLAN new-routing-mark=DiraWAN1 passthrough=yes 
    • add action=mark-routing chain=prerouting connection-mark=DD02 in- interface=BridgeLAN new-routing-mark=DiraWAN2 passthrough=yes

Thẻ IPFirewallMangle

huong-dan-cau-hinh-load-balancing-wan-6.png

huong-dan-cau-hinh-load-balancing-wan-router-mikrotik.png

→ Việc đánh dấu bước trên với 2 giá trị “DD01” và “DD02” được chuyển sang đường đi ra ngoài Internet tương ứng “DiraWAN1” và “DiraWAN2”.

  • Cụm 4:
    • add action=mark-routing chain=output connection-mark=VaoWAN1 new- routing-mark=DiraWAN1 passthrough=yes
    • add action=mark-routing chain=output connection-mark=VaoWAN2 new- routing-mark=DiraWAN2 passthrough=yes

Thẻ IPFirewallMangle

huong-dan-cau-hinh-load-balancing-wan-5.png

→ Việc đánh dấu các kết nối ở cụm số 1 được chuyển sang đường đi ra ngoài Internet tương ứng “DiraWAN1” và “DiraWAN2”.

  • Cụm 5:
    • add check-gateway=ping distance=1 gateway=pppoe-out1 routing- mark=DiraWAN1
    • add check-gateway=ping distance=1 gateway=pppoe-out2 routing- mark=DiraWAN2

Thẻ IP → Route

huong-dan-cau-hinh-load-balancing-wan-router-mikrotik-2.png

→ Lập đường đi mới từ các đường đi Internet có sẵn kèm theo gán nhãn cho các đường mới này, tương ứng “DiraWAN1” và “DiraWAN2”.

Dựa vào đường đi chính đã có sẵn để hiện thực hóa đường đi đã khởi tạo trước đây.

Kết luận

Trên đây là toàn bộ hướng dẫn cân bằng tải 2 WAN hoặc nhiều WAN sử dụng phương pháp PCC trên Router MikroTik. Chúc các bạn cấu hình thành công!

Cảm ơn bạn đã theo dõi bài viết! 

Nếu có bất kỳ thắc mắc nào về MikroTik, đừng ngần ngại liên hệ với chúng tôi nhé! Đừng quên cập nhật Viettuans.vn thường xuyên để có thêm nhiều thông tin hữu ích về kiến thức mạng, quản trị mạng cũng như các kiến thức hướng dẫn sử dụng trong chuyên mục MikroTik.

VIỆT TUẤN - NHÀ PHÂN PHỐI THIẾT BỊ MẠNG, WIFI, THIẾT BỊ LƯU TRỮ NAS CHÍNH HÃNG

Chia sẻ

Nguyễn Lưu Minh

Chuyên gia của Viettuans.vn với nhiều năm kinh nghiệm trong lĩnh vực thiết bị mạng Networks, System, Security và tư vấn, triển khai các giải pháp CNTT. Phân phối thiết bị mạng, wifi, router, switch, tường lửa Firewall, thiết bị lưu trữ dữ liệu NAS.

0903.209.123
0903.209.123